Something is wrong with my XML Sitemap, how to fix

by anonymous   Last Updated March 10, 2019 12:04 PM

My question is related to my previous question How to remove indexed pages from google effectively where I was advised to create XML sitemap and submit it to google. The advice looked solid so I created one.

Now when I created my custom sitemap and submitted to google, it did not pick any url of it and basically every url has error in it. I did replace &,',",(space) and other characters to properly url encode all the links but I am still getting the error. I did verify my sitemap from third party (xml-sitemap) and it reported no error. I want to know what am I doing wrong

enter image description here

enter image description here

Here is the sitemap snippet

<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
<url>
<loc>
www.peshawar.co/search.php?keywords=&amp;city=peshawar
</loc>
<lastmod>2019-03-10</lastmod>
<changefreq>weekly</changefreq>
<priority>0.8</priority>
</url>
<url>
<loc>
www.peshawar.co/search.php?keywords=17%20Inquiry&amp;city=peshawar
</loc>
<lastmod>2019-03-10</lastmod>
<changefreq>weekly</changefreq>
<priority>0.8</priority>
</url>
<url>
<loc>
www.peshawar.co/search.php?keywords=3D%20Printers&amp;city=peshawar
</loc>
<lastmod>2019-03-10</lastmod>
<changefreq>weekly</changefreq>
<priority>0.8</priority>
</url>

Here is the actual sitemap which contains 34k links and takes a while to download. Could it be the size of XML that is causing the problem? (Highly unlikely though)



Related Questions


Updated November 29, 2018 18:04 PM

Updated January 12, 2018 08:04 AM

Updated March 22, 2017 14:04 PM

Updated June 21, 2017 02:04 AM

Updated June 29, 2017 11:04 AM