Nonbonded interactions on the GPU were required, but not supported for these simulation settings.

by Erfan   Last Updated October 11, 2018 15:02 PM

I get this error when I run Gromax on GPU Where can the problem be?

Thanks

GROMACS: gmx mdrun, version 2018 Executable: /opt/Gromacs-5.1.4/bin/gmx Data prefix: /opt/Gromacs-5.1.4 Working dir: /home/linux/Downloads/test Command line: gmx mdrun -deffnm md -nb Agpu

Back Off! I just backed up md.log to ./#md.log.7# NOTE: GPUs cannot be detected:

  CUDA driver version is insufficient for CUDA runtime version
  Can not use GPU acceleration, will fall back to CPU kernels.

Reading file md.tpr, VERSION 2018.3 (single precision)

Multiple energy groups is not implemented for GPUs, falling back to the CPU. For better performance, run on the GPU without energy groups and then do gmx mdrun -rerun option on the trajectory with an energy group .tpr file.


Program: gmx mdrun, version 2018 Source file: src/gromacs/taskassignment/decidegpuusage.cpp (line 292) Function: bool gmx::decideWhetherToUseGpusForNonbonded(gmx::TaskTarget, const std::vector&, EmulateGpuNonbonded, bool, bool, bool)

Inconsistency in user input:

Nonbonded interactions on the GPU were required, but not supported for these simulation settings. Change your settings, or do not require using GPUs.

For more information and tips for troubleshooting, please check the GROMACS

website at http://www.gromacs.org/Documentation/Errors



Related Questions


Updated April 18, 2018 19:02 PM

Updated March 13, 2017 22:02 PM

Updated March 31, 2016 08:01 AM

Updated January 22, 2018 20:02 PM

Updated June 15, 2017 08:02 AM