Mouse "pixel slipping" issue

by Mona the Monad   Last Updated October 10, 2019 01:01 AM

All of my mice exhibit a strange "pixel slipping" behaviour. The cursor will sometimes "slip" by a pixel in some direction, usually a hundred to a few hundred milliseconds after stopping the mouse to click on something, or even just to hover over something.

I've tested all of my functional mice (from cheap generic USB mice, to a budget gaming mouse, to a brand new Logitech G502 Hero), each on various surfaces (on my desk, on a manilla folder, on a QcK mousepad, and on a wooden board), with various weights (if applicable), different USB ports, different combinations of DPI and sensitivity, and even different operating systems (Windows and Ubuntu). In every circumstance, the same slipping behaviour is exhibited.

My personal guess is that it's probably not an issue with the mice (a brand new G502 should definitely not pixel slip ever), but I'm not sure what the issue could be.

To sort of test if it's really my own hand that is unstable or something, or if something is up with the static friction of the mice, I sometimes try to "wiggle" the mice with a force that is just under its static friction. The cursor stays put as it should, but only after slipping once, if it does slip. That is, it doesn't quite seem like a friction issue, either.

Lastly, this is even more weird, because this same behaviour is exhibited at my work computer, with an Amazon Basics mouse, which tends to slip by a few pixels, even with its gummy feet sticking to the table when I stop moving it.

What could possibly be causing this strange behaviour?

Tags : usb mouse


Related Questions


Updated August 21, 2019 06:01 AM

Updated November 30, 2018 23:01 PM

Updated February 10, 2019 15:01 PM

Updated September 07, 2019 12:01 PM

Updated August 16, 2015 21:00 PM