Issue with Serverless deploy of smart contract-Dependency mismatch -Package.json,Package-lock.json error

by Ashadipta   Last Updated July 11, 2019 09:28 AM

I am trying to deploy my smart contract serverless(AWS lambda).I am using Truffle framework.The code is getting deployed in an earlier system(earlier it was deployed here).Now I have updated the smart contract version .When I am deploying it.I am not able to in my new system due to dependencies mismatch n version change.I tested my smart contract in local system using ganache.there uts working fine.When deploying serverless I am getting the issue. Below is the error screenshot enter image description here - Below are the dependencies in package.json. "aws-sdk": "^2.256.1", "express": "^4.16.3", "fs": "0.0.1-security", "openzeppelin-solidity": "^1.12.0", "pug": "^2.0.3", "solc": "^0.4.24", "web3": "^1.0.0-beta.50"

and all the above have been updated to newer versions..

Tags : truffle aws


Related Questions


Updated March 12, 2018 22:28 PM

Updated April 04, 2019 06:28 AM

Updated March 30, 2018 08:28 AM

Updated April 02, 2018 17:28 PM

Updated April 05, 2018 17:28 PM