I get General HTTP error: 404 not found when submiting sitemap?

by Fin   Last Updated May 08, 2017 06:04 AM

I just bought 2 domain from domaindiscount24.com. I get an error: "General HTTP error: 404 not found" when submitting sitemap. Then, I use "fetch as googlebot" and my website URL, it showed "not found". However, I make sure my website and sitemap work because I can access my website. Also, I use some online tools to check sitemap and they showed "valid sitemap". I don't know what happen. Maybe googbot don't want to access to these website. I am sure I am not block anything in htaccess and robots.txt

With domain I buy from godaddy, it is fine. So, what do you know what problem I facing ?



Answers 1


Just delete your website sitemap on Google web master tools, and resubmit your sitemap. Make sure you removed all your unwanted pages, posts and elements from your coding structure.

If your are using word press it is better to use Yoast plugin for sitemap because it gives an option to choose which pages, posts and elements to get added on your sitemap and exclude unwanted elements.

Access all urls of your website in your browser and check for 404 errors and try to redirect these urls to relevant pages of your website.

This will help understanding about what is happening in your sitemap.

Note: If your resubmit your sitemap, all previous errors will be shown for at least 24 hours and so you can only see your sitemap errors after two days from the day you submitted.

satish k
satish k
December 29, 2014 08:45 AM

Related Questions


Updated June 21, 2017 02:04 AM

Updated March 17, 2016 08:01 AM

Updated March 10, 2018 11:04 AM

Updated January 23, 2019 14:04 PM