I Cannot Update Past 17.10

by cjd95031   Last Updated May 16, 2019 05:02 AM

This is kind of a long story, but I'll try to keep it simple and to the point.

My hard drive with Windows 10 on it broke. I'm not sure why, and the actual hardware is fine, but the installation was beyond repair. I was trading hard disks between computers as I was upgrading to a new machine, and must have done something wrong that caused it to throw a fatal fit. Whoops.

In any case, I could boot of a live USB, but installing CentOS from a UEFI bootable didn't work (said something about not being able to activate the port). Then I remembered all the Linux distros I had lying around which I burned on disks a few years ago. I popped in the Ubuntu disk, went through the installation process and everything was fine. Almost everything.

The trouble is, I'm on version 17.10, and the software updater isn't pushing any new system updates to me. Whenever I look for packages in the terminal, it can't find them. I don't know if all my problems will be solved by updating to the latest version, but it's a start.

What should I do next?

Thanks!

P.S. I'm connected to the internet via cord and I can also access it wirelessly.



Related Questions


Updated July 18, 2018 01:02 AM

Updated January 20, 2018 21:02 PM

Updated August 20, 2017 21:02 PM

Updated June 13, 2017 18:02 PM