Exporting particle simulation as Alembic - animation issues

by Summer   Last Updated May 15, 2019 22:15 PM

I need to export a particle simulation with an emission setting of 1000 particles and lifetime 50 as an Alembic file for Keyshot.

The issue is when I import into Keyshot, it only imports a portion of the particles - the ones that are visible in the outliner. So whatever frame I'm on will affect what particles will export, which may be 200 particles out of 1000 for example. In Keyshot, the particles also don't turn off after they reach their life time, they just pause in place as the animation continues to the end.

How can I export an Alembic file that recognizes particle visibility/animation? I'd appreciate any help - please let me know if I should upload any files for clarity.

Here's a part of the outliner after running the script, so the animation is still preserved in Blender it seems, just maybe not linked as well to be exported?

enter image description here

Here's the process I used:

1) Bake All Dynamics on particle simulation

2) Convert particles to meshes via script (first select dupli object, then particle system)

3) Auto-keyframe animation (turned this on and played the animation, then turned it off). I don't know if this made a difference or if I even used it correctly. Exported with and without this step and got the same Keyshot result.

4) Exported Alembic, imported into Keyshot.

Thanks!



Related Questions


Updated March 01, 2018 15:15 PM

Updated May 14, 2019 06:15 AM

Updated January 08, 2018 10:15 AM

Updated September 17, 2017 11:15 AM

Updated May 24, 2018 00:15 AM